Search This Blog

Wednesday, October 21, 2009

Enable Reporting for VMM

Let proceed to enable the reporting features for VMM. I'm assumed you've successfully integrate SCOM with VMM.

In VMM 2008 R2, you do not need to import Virtual Machine Manager 2008 R2 MP, as the system will automatically install the MP after the installation.



















Proceed to follow the below step by step instruction:-

1. On the Operation Manager console, go to Administration pane, under security , click User roles
2. Double Click Operation Manager Report Operator, click Add on the user role member and enter VMM administrator. This allow administrator to view and open report in VMM.











3. Go to VMM Console, In the Administration pane, click System Center
4. In the detail pane, double click Operation Manager Reporting URL
5. Select Enable reporting and enter http://scom01/reportserver



















6. Once you have click OK, In the left pane, you will see an Additional pane called "Reporting" is visible.


7. Here is a sample result when you open Host Utilization Report


Report can export to the following formats:-



Look cool right !

4 comments:

  1. Hi Lai

    I dont get the reporting to work that way. I get "Error while connecting to the reporting server. Ensure that Virtual Machine Manager management pack and its reports are installed on the Operations Manager server. ID: 3451". The MPs are installed by VMM, should be fine. Do you have an idea how to solve this?

    Thanks a lot, Norbert

    ReplyDelete
  2. Hi,

    Did you manage to get the integration working? Pls refer to this link:- http://www.ms4u.info/2009/10/integrate-operation-manager-with-vmm.html.

    ReplyDelete
  3. Hi, Just encounter the same error message.

    For workaround, pls refer to http://www.ms4u.info/2010/03/error-while-connecting-to-reporting.html

    ReplyDelete
  4. Excellent post Lai. the issue with Reporting for me with the URL didn't match exactly. I had to disable reporting in SCVMM and then enable and add the correct URL then it started working. All in all your post along with the following were are a great help, thank you very much for this most excellent blog!
    http://blogs.southworks.net/aortega/2009/07/22/deploying-system-center-operations-manager-r2-rc/

    Cheers,
    -Dave

    ReplyDelete